BrandonF - 2004 JDM Subaru Legacy 2.0GT 5MT



west_minist
Site Admin
Posts: 1757
Joined: Sun May 20, 2007 11:08 pm
Location: Barbados
Contact:

Re: 2004 JDM Subaru Legacy 2.0GT 5MT w/ Turboback Exhaust System

Post by west_minist » Thu Feb 11, 2010 11:39 pm

v27c 4th gear Dyno IAT=33C.png
v27c 4th gear Dyno IAT=33C.png (14.78 KiB) Viewed 4292 times

ScoobyTT
X-Tuned
Posts: 3
Joined: Mon Oct 05, 2009 3:19 pm
Location: Trinidad

Re: 2004 JDM Subaru Legacy 2.0GT 5MT w/ Turboback Exhaust Sy

Post by ScoobyTT » Tue Jun 15, 2010 5:42 pm

So 2 quick updates:

DBW Tuning Experience - After Edward made changes, I noticed a sharper, more responsive throttle. a lot less effort required to engage power from the engine. WOT feeling at about 50-60% throttle. Took some getting used to, as she was more "sensitive" so to speak. It was a little awkward at first, but tuning forced me to get more in feel with the car, more intimate if I would say. Once I got used to it, it was good. It became easier to understand the car's expected reaction to my actions. Initially, I didn't quite understand what aspects of the Legacy were DBW, but I thought the ability to alter the throttle response with tuning was great, real interesting stuff. As usual, Edward's guidance was golden as I "relearned" my own car :D .


Power Loss - It started to get more noticeable about 2-3 weeks now. A considerable loss in power in high boost, car would make this skipping noise, sort of pulsing sound. Only @ WOT I would get this. Working with Edward, and at the height of my frustration :evil: , everything seems to point to a leaking BOV. When the boost psi was reduced to 14, I would not get the issue, it only occurred if the PSI went beyond 14 or 14.5 or so. On my boost guage, this is equivalent to 1 Bar. So anything over 14.5 psi/1 Bar causes a problem. So I'll soon be going with an aftermarket BOV, hoping that is the problem, praying actually, :roll: .

west_minist
Site Admin
Posts: 1757
Joined: Sun May 20, 2007 11:08 pm
Location: Barbados
Contact:

Re: 2004 JDM Subaru Legacy 2.0GT 5MT w/ Turboback Exhaust Sy

Post by west_minist » Sun Jul 11, 2010 9:24 am

From: ScoobyTT
Date: Sun, Jul 11, 2010 at 9:20 AM
Subject: Re: Have fun :)
To: SOCOB SOCOB <socob.bb@gmail.com>


So v37. The response of the car is back! Power n tq seem instant. At
WOT its still not what I rem it to be, but its the best its been in
months. The antilag is well, for the least, interesting. It makes me
have to drive her differently. During shifts, without gas she
backfires, so its almost like she needs a lil throttle, lol. This
however brings immediate power n tq as soon as I'm in the next gear.
Makes for high speed shifting fun n power! I still don't know what the
term antilag means, but I know how it feels, lol! I have not been this
excited driving my car in months. I guess she needs new plugs, and
I'll see what the leak tests come up with. Also need to get that wb
logging asap. Will give her a full service month end plugs and oil.

west_minist
Site Admin
Posts: 1757
Joined: Sun May 20, 2007 11:08 pm
Location: Barbados
Contact:

Re: 2004 JDM Subaru Legacy 2.0GT 5MT w/ Turboback Exhaust Sy

Post by west_minist » Sun Nov 06, 2011 10:05 am

Early Dyno sessions
IMG-20111106-00075.jpg
IMG-20111106-00075.jpg (48.61 KiB) Viewed 4001 times
IMG-20111106-00076.jpg
IMG-20111106-00076.jpg (50.01 KiB) Viewed 4001 times
Issues noted:
BOV, Wastegate, etc

Post Reply

Return to “LGT”